summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2013-11-30 22:07:38 +0100
committerDavid Kalnischkies <kalnischkies@gmail.com>2013-11-30 23:34:15 +0100
commit0005fa07886135d6adfec59f2d722df229b7af12 (patch)
treebb04eff93bf09d62bf910f825ee0071aaaf5d8c4 /debian/rules
parent694ef56e802bbab94595fc491fdc6ef8b4f525c1 (diff)
use a substvar to set the archive-keyring in debian/control
Adds a small helper to extract the small information bits we store in apt-vendor.ent and uses it in debian/rules to set apt:keyring as a substvar for debian/control populated with the &keyring-package; info
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 28525af50..f4f7ec06b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -219,7 +219,7 @@ apt: build-binary build-manpages debian/apt.install
dh_fixperms -p$@
dh_installdeb -p$@
dh_shlibdeps -p$@
- dh_gencontrol -p$@
+ dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
dh_md5sums -p$@
dh_builddeb -p$@