summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2011-01-15 02:43:13 +0100
committerDavid Kalnischkies <kalnischkies@gmail.com>2011-01-15 02:43:13 +0100
commit149daa16569b1763ab0ed76cc1fd80455980eddc (patch)
tree31f56b4d1bf5c48e5aebbd3b613dbccab8606e89 /debian/rules
parent8d13be63fb62d683bf41d32295652c0780421cd4 (diff)
* debian/control:
- depend on dpkg-dev (>= 1.15.8) to have c++ symbol mangling * debian/rules: - remove shlibs.local creation and usage - show differences in the symbol files, but never fail * debian/{apt,apt-utils}.symbols: - ship experimental unmangled c++ symbol files
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules37
1 files changed, 12 insertions, 25 deletions
diff --git a/debian/rules b/debian/rules
index fbd309e97..fd872b4ce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -74,18 +74,8 @@ include buildlib/libversion.mak
LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
-debian/shlibs.local: apt-pkg/makefile
- # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
- # one for the rest of the packages. This ensures that each package gets
- # the right overrides…
- rm -rf $@ $@.apt $@.apt-utils
- echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
-
- echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
- echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
-
- echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
- echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+# do not fail as we are just experimenting with symbol files for now
+export DPKG_GENSYMBOLS_CHECK_LEVEL=0
build: build/build-stamp
build-doc: build/build-doc-stamp
@@ -120,12 +110,9 @@ clean:
[ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
- # Add here commands to clean up after the build process.
- dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
-
binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
-libapt-pkg-doc: build-doc debian/shlibs.local
+libapt-pkg-doc: build-doc
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -177,7 +164,7 @@ apt-doc: build-doc
binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-doc debian/shlibs.local
+apt: build build-doc
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -226,14 +213,14 @@ apt: build build-doc debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
+ dh_makeshlibs -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
-libapt-pkg-dev: build debian/shlibs.local
+libapt-pkg-dev: build
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -258,7 +245,7 @@ libapt-pkg-dev: build debian/shlibs.local
dh_builddeb -p$@
apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build debian/shlibs.local
+apt-utils: build
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -279,14 +266,14 @@ apt-utils: build debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
+ dh_makeshlibs -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+ dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
dh_gencontrol -p$@ -- -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
-apt-transport-https: build debian/shlibs.local libapt-pkg-dev
+apt-transport-https: build libapt-pkg-dev
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -321,4 +308,4 @@ really-clean: clean
rm -f l33ch-stamp
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
+.PHONY: build clean binary-indep binary-arch binary