summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2016-05-25 08:27:58 +0200
committerDavid Kalnischkies <david@kalnischkies.de>2016-05-25 08:27:58 +0200
commita97127c3d019ee073c078dbb652a12386f58515b (patch)
tree71d26ff22f36456def45100ee35ad47d4e9f8688 /debian/rules
parent83defe877fad2684179d9ddb6e2a40857c3a89e9 (diff)
remove semi-support for different build-dirs
The debian/rules file tries to guess in which directory it is supposed to be building, but that guess is always ./build – if it wasn't it would fail later as not all rules take alternatives into acount. So, as this is clearly not used lets remove this complexity instead of fixing it up. Git-Dch: Ignore
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 2 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 9c7f456e3..bdc539fef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,23 +42,9 @@ endif
# Default rule
build:
-PKG=apt
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-
# Determine the build directory to use
-BASE=.
-ifdef BUILD
-BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
-else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
-endif
-BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
-BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
-override BLD := $(BUILDX)
-
-ifeq ($(words $(BLD)),0)
-override BLD := ./build
-endif
+override BASE := .
+override BLD := $(BASE)/build
# When building without <nocheck>, the header is available and thus the test is
# successful. When building with <nocheck>, the header is missing, but we still