summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2007-07-14 16:57:15 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2007-07-14 16:57:15 +0100
commitf0efdda074effd4b8d668c1adfd6ddc4be698ae9 (patch)
tree448d69dfba458f406850cfd672f4c33fcfce26f1 /debian/rules
parenta975773b97214620c750cb2465e01f811a33831d (diff)
parent82d0afc286514bbe8904c3436bb6580aeaa6ad66 (diff)
* Simplified HttpMethod::Fetch on http.cc removing Tail variable;
* Fix pipeline handling on http.cc (closes: #413324) * Fix building to properly support binNMUs. Thanks to Daniel Schepler <schepler@math.unipd.it> by the patch (closes: #359634) * Fix example for Install-{Recommends,Suggests} options on configure-index example file. Thanks to Peter Eisentraut <peter_e@gmx.net> by the patch (closes: #432223) *
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index daf15fe1b..6ad6b7c84 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')