summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2009-09-23 17:26:43 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2009-09-23 17:26:43 +0200
commitf98233c1b1e93ef1bb595bfc6e59c74d9e05eb6a (patch)
tree82d6aa3ff7c2c2e6d073ff39f09e52aa7407562d /debian/rules
parenta69a3a044be84f72508fb468cdf13d9e5f724dd4 (diff)
parentf7d6459db697c6dbba8e5d787a817e7721bfb577 (diff)
merged from debian
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 8e2b18f67..2a18f4f47 100755
--- a/debian/rules
+++ b/debian/rules
@@ -186,6 +186,7 @@ apt-doc: build-doc
# Build architecture-dependent files here.
binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
apt: build build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -232,7 +233,7 @@ apt: build build-doc debian/shlibs.local
debian/$@/usr/lib/apt/apt-report-mirror-failure \
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installman -p$@
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
dh_installcron -p$@
dh_installdocs -p$@
dh_installchangelogs -p$@
@@ -275,6 +276,7 @@ libapt-pkg-dev: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
apt-utils: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -290,7 +292,7 @@ apt-utils: build debian/shlibs.local
dh_installexamples -p$@
# Install the man pages..
- dh_installman -p$@
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
dh_installchangelogs -p$@
dh_strip -p$@