summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:59:44 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:59:44 +0000
commit045ba6138db2a27849fbd04aa545b6151b235a11 (patch)
treeb47410cbf94e1b61f65d2d5146738917e43d55a1 /debian
parent209836e2c1ad9618735a2db8806657c5207e166f (diff)
Add support for DEB_HOST_GNU_TYPE and DEB_BUILD_GNU_TYP...
Author: doogie Date: 2002-11-09 20:13:27 GMT Add support for DEB_HOST_GNU_TYPE and DEB_BUILD_GNU_TYPE detection.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules14
1 files changed, 12 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ffbc7a427..e8a336325 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.39 2002/11/09 06:34:13 doogie Exp $
+# $Id: rules,v 1.40 2002/11/09 20:13:27 doogie Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -16,6 +16,16 @@
export DH_COMPAT=2
+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+ confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+ confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
# See below
-include build/environment.mak
@@ -90,7 +100,7 @@ build/configure-stamp: configure
dh_testdir
-mkdir build
cp COPYING debian/copyright
- (cd build; ../configure)
+ (cd build; ../configure $(confflags))
touch $@
build/build-stamp: build/configure-stamp