summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2014-04-25 18:18:28 +0200
committerMichael Vogt <mvo@debian.org>2014-04-25 18:18:28 +0200
commit12701ee3e5a637e5e45c633dc9aa2b16b81df0b8 (patch)
tree8cf529268e9a8a297ffcbe0e412a25a9e81be462 /debian
parent697c9314c8ba24f3e393b5de11a3fad7adae4bfc (diff)
provide support for debian/apt.conf.$(lsb_release -i -s) vendor specific config files
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.conf.Ubuntu6
-rw-r--r--debian/apt.maintscript3
-rwxr-xr-xdebian/rules7
3 files changed, 16 insertions, 0 deletions
diff --git a/debian/apt.conf.Ubuntu b/debian/apt.conf.Ubuntu
new file mode 100644
index 000000000..c4092ff44
--- /dev/null
+++ b/debian/apt.conf.Ubuntu
@@ -0,0 +1,6 @@
+// Server information for apt-changelog
+APT {
+ Changelogs {
+ Server "http://changelogs.ubuntu.com/changelogs";
+ };
+};
diff --git a/debian/apt.maintscript b/debian/apt.maintscript
new file mode 100644
index 000000000..939769355
--- /dev/null
+++ b/debian/apt.maintscript
@@ -0,0 +1,3 @@
+rm_conffile /etc/apt/apt.conf.d/20changelog 1.0.3 -- "@"
+
+
diff --git a/debian/rules b/debian/rules
index 196761444..300c0f756 100755
--- a/debian/rules
+++ b/debian/rules
@@ -56,6 +56,9 @@ endif
# APT Programs in apt-utils
APT_UTILS=ftparchive sortpkgs extracttemplates
+# get distro
+APT_VENDOR_CONF := $(shell lsb_release -i -s)
+
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -191,6 +194,10 @@ apt: build-binary build-manpages debian/apt.install
chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
# install bash completion
cp share/bash-completions/* debian/$@/usr/share/bash-completion/completions/
+ # install distro specific apt conf
+ if [ -e debian/apt.conf.${APT_VENDOR_CONF} ]; then \
+ cp debian/apt.conf.${APT_VENDOR_CONF} debian/$@/etc/apt/apt.conf.d/01-vendor-${APT_VENDOR_CONF}; \
+ fi
# make rosetta happy and remove pot files in po/ (but leave stuff
# in po/domains/* untouched) and cp *.po into each domain dir