summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:00:52 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:00:52 +0000
commit16c76dd2cb44a67a581ff0888d6ff47a9e72ab4c (patch)
treebce82de895785dc6e1395d7bf1a62a2d81234d3e /debian
parenta7cf4273ca0d5e47622bf278b547a4e984afbf4b (diff)
Move the guide and offline docs to a separate package. ...
Author: doogie Date: 2003-02-12 07:39:45 GMT Move the guide and offline docs to a separate package. This allows us to split the build-deps, so binary-arch builds are not as heavyweight.
Diffstat (limited to 'debian')
-rw-r--r--debian/.cvsignore1
-rw-r--r--debian/apt-doc.dhelp (renamed from debian/dhelp)0
-rw-r--r--debian/control17
-rwxr-xr-xdebian/rules38
4 files changed, 48 insertions, 8 deletions
diff --git a/debian/.cvsignore b/debian/.cvsignore
index f7bd68df9..caad88f68 100644
--- a/debian/.cvsignore
+++ b/debian/.cvsignore
@@ -1,5 +1,6 @@
copyright
apt
+apt-doc
apt-utils
apt-utils.substvars
apt.substvars
diff --git a/debian/dhelp b/debian/apt-doc.dhelp
index 091c49956..091c49956 100644
--- a/debian/dhelp
+++ b/debian/apt-doc.dhelp
diff --git a/debian/control b/debian/control
index 0361d7989..2c66f9d3c 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,8 @@ Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Jason Gunthorpe <jgg@debian.org>, Adam Heath <doogie@debian.org>
Standards-Version: 3.5.8.0
-Build-Depends: debhelper (>= 2), debiandoc-sgml, docbook-utils (>= 0.6.12-1), libdb2-dev, gettext (>= 0.11.5)
+Build-Depends: debhelper (>= 2), libdb2-dev, gettext (>= 0.11.5)
+Build-Depends-Indep: debiandoc-sgml, docbook-utils (>= 0.6.12-1)
Package: apt
Architecture: any
@@ -12,7 +13,7 @@ Depends: ${shlibs:Depends}
Priority: standard
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
-Suggests: dpkg-dev
+Suggests: dpkg-dev, apt-doc
Section: base
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
@@ -20,8 +21,16 @@ Description: Advanced front-end for dpkg
simpler, safer way to install and upgrade packages.
.
APT features complete installation ordering, multiple source capability
- and several other unique features, see the Users Guide in
- /usr/share/doc/apt/guide.text.gz
+ and several other unique features, see the Users Guide in apt-doc.
+
+Package: apt-doc
+Architecture: all
+Priority: optional
+Replaces: apt (<< 0.5.4.9)
+Section: doc
+Description: Documentation for APT
+ This package contains the user guide and offline guide, for APT, an
+ Advanced Package Tool.
Package: libapt-pkg-dev
Architecture: any
diff --git a/debian/rules b/debian/rules
index 3361f0e1f..40f6087bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.45 2003/02/02 22:00:24 doogie Exp $
+# $Id: rules,v 1.46 2003/02/12 07:39:45 doogie Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -88,6 +88,7 @@ debian/shlibs.local: apt-pkg/makefile
echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
build: build/build-stamp
+build-doc: build/build-doc-stamp
# Note that this is unconditionally done first as part of loading environment.mak
# The true is needed to force make to reload environment.mak after running
@@ -113,7 +114,12 @@ endif
build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
- $(MAKE) -s
+ $(MAKE) binary
+ touch $@
+
+build/build-doc-stamp: build/configure-stamp
+ # Add here commands to compile the package.
+ $(MAKE) doc
touch $@
clean:
@@ -127,9 +133,9 @@ clean:
# Add here commands to clean up after the build process.
dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
-binary-indep: libapt-pkg-doc
+binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
-libapt-pkg-doc: build debian/shlibs.local
+libapt-pkg-doc: build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
@@ -161,6 +167,30 @@ libapt-pkg-doc: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
+apt-doc: build-doc
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_clean -p$@ -k
+#
+# apt-doc install
+#
+ # Copy the guides
+ dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
+ $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+
+ # One or the other..
+ -cp -a debian/apt-doc.dhelp debian/apt/usr/doc/apt-doc/.dhelp
+ -cp -a debian/apt-doc.dhelp debian/apt/usr/share/doc/apt-doc/.dhelp
+
+ dh_installchangelogs -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+
# Build architecture-dependent files here.