summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2010-10-13 22:27:56 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2010-10-13 22:27:56 +0200
commit2faaf8bea85149fb131735a6bd7437fec3771ee0 (patch)
tree6c6ccb53abac45fdf9cb1f6fb3991ac4bcecb5c1 /debian
parent3b9c5cc2bdf1584525792aafe4e8f15d09951583 (diff)
parentbe61b563c20267c521494cca92bd7ac158366c89 (diff)
merge with debian-sid
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily7
-rw-r--r--debian/changelog20
2 files changed, 27 insertions, 0 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 8ace14a31..c61bfb9bb 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -417,6 +417,13 @@ do_cache_backup $BackupArchiveInterval
# mirrors at the same time
random_sleep
+# include default system language so that "apt-get update" will
+# fetch the right translated package descriptions
+if [ -r /etc/default/locale ]; then
+ . /etc/default/locale
+ export LANG LANGUAGE LC_MESSAGES LC_ALL
+fi
+
# update package lists
UPDATED=0
UPDATE_STAMP=/var/lib/apt/periodic/update-stamp
diff --git a/debian/changelog b/debian/changelog
index c7aead5bb..9126e9dc3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,26 @@ apt (0.8.7) UNRELEASED; urgency=low
* Another typo fixed in French ("Anfin"). Thanks to bubulle
* Wrong translation for "showauto" fixed. Thanks to Raphaƫl Hertzog
Closes: #599265
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - source /etc/default/locale (if available) so that the
+ apt-get update cron job fetches the right translated package
+ descriptions
+ * fix test failure on amd64
+ * apt-pkg/deb/debsystem.cc:
+ - fix issues with dir::state::status and dir::state::extended_states
+ when alternative rootdirs are used
+
+ [ Martin Pitt ]
+ * apt-pkg/deb/debindexfile.cc:
+ - Use FileFd::Size() instead of stat()ing the sources/binary/translations
+ indexes directly, so that we have transparent handling of gzipped
+ indexes.
+ * apt-pkg/contrib/fileutl.cc:
+ - Fix FileFd::Size() for gzipped files to give the size of the
+ uncompressed data. This fixes cache building progress going way
+ over 100%.
[ David Kalnischkies ]
* apt-pkg/deb/deblistparser.cc: