summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2007-10-02 13:52:22 +0200
committerMichael Vogt <egon@bottom>2007-10-02 13:52:22 +0200
commit3346b385523c596c1db7667b4874a8617718de70 (patch)
tree9bef8479ffdc2e80ae83ffdf02255aac0b0beb9d /debian
parent36fc5dca8b8eaa38a4ebd3ec52b462df44dd1b82 (diff)
parent59d5cc74ef7c6ca820ed9d26a4d829b891214edf (diff)
- fix parse error when dpkg sends unexpected data
* fix missing SetExecClose() call when the status-fd is used * debian/apt.cron.daily: - move unattended-upgrade before apt-get autoclean * fix "purge" commandline argument, closes: #133421 (thanks to Julien Danjou for the patch) * cmdline/apt-get.cc: - do not change the auto-installed information if a package is reinstalled * apt-pkg/acquire-item.cc: - fix crash in diff acquire code * cmdline/apt-mark: - Fix chmoding after have renamed the extended-states file (LP: #140019) (thanks to Laurent Bigonville) * apt-pkg/contrib/mmap.cc: - don't fail if msync() returns > 0
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily12
-rw-r--r--debian/changelog18
2 files changed, 24 insertions, 6 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 778e3cefe..34d6b164f 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -186,17 +186,17 @@ if check_stamp $DOWNLOAD_UPGRADEABLE_STAMP $DownloadUpgradeableInterval; then
update_stamp $DOWNLOAD_UPGRADEABLE_STAMP
fi
-AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
-if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
- apt-get -qq autoclean
- update_stamp $AUTOCLEAN_STAMP
-fi
-
UPGRADE_STAMP=/var/lib/apt/periodic/upgrade-stamp
if check_stamp $UPGRADE_STAMP $UnattendedUpgradeInterval; then
unattended-upgrade
update_stamp $UPGRADE_STAMP
fi
+AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
+if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
+ apt-get -qq autoclean
+ update_stamp $AUTOCLEAN_STAMP
+fi
+
# check cache size
check_size_constraints
diff --git a/debian/changelog b/debian/changelog
index b4870ba64..bd8562f9c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,7 @@ apt (0.7.7) UNRELEASED; urgency=low
- merged dpkg-log branch, this lets you specify a
Dir::Log::Terminal file to log dpkg output to
(ABI break)
+ - fix parse error when dpkg sends unexpected data
* merged apt--sha256 branch to fully support the new
sha256 checksums in the Packages and Release files
(ABI break)
@@ -25,6 +26,19 @@ apt (0.7.7) UNRELEASED; urgency=low
- increase MaxPipeDepth for the internal worker<->method
communication to 1000 for the debtorrent backend
* make apt build with g++ 4.3
+ * fix missing SetExecClose() call when the status-fd is used
+ * debian/apt.cron.daily:
+ - move unattended-upgrade before apt-get autoclean
+ * fix "purge" commandline argument, closes: #133421
+ (thanks to Julien Danjou for the patch)
+ * cmdline/apt-get.cc:
+ - do not change the auto-installed information if a package
+ is reinstalled
+ * apt-pkg/acquire-item.cc:
+ - fix crash in diff acquire code
+ * cmdline/apt-mark:
+ - Fix chmoding after have renamed the extended-states file (LP: #140019)
+ (thanks to Laurent Bigonville)
[ Program translations ]
- French updated
@@ -46,6 +60,10 @@ apt (0.7.7) UNRELEASED; urgency=low
[ Ian Jackson ]
* dpkg-triggers: Deal properly with new package states.
+ [ Colin Watson ]
+ * apt-pkg/contrib/mmap.cc:
+ - don't fail if msync() returns > 0
+
-- Otavio Salvador <otavio@debian.org> Mon, 06 Aug 2007 10:44:53 -0300
apt (0.7.6) unstable; urgency=low