summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:52:44 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:52:44 +0000
commit396f4b089b11a70de94eac21cb9ba3aca3fee281 (patch)
tree17448da698139530665361737d4a37bebc429451 /debian
parentb381f6ed580f9c58c1547fddd92af1b52fc5a1f0 (diff)
dhelp support, sorta
Author: jgg Date: 1999-02-02 02:19:46 GMT dhelp support, sorta
Diffstat (limited to 'debian')
-rw-r--r--debian/dhelp10
-rw-r--r--debian/libapt-pkg-doc.dhelp61
-rwxr-xr-xdebian/libapt-pkg-doc.postinst10
-rwxr-xr-xdebian/libapt-pkg-doc.prerm11
-rwxr-xr-xdebian/postinst4
-rwxr-xr-xdebian/rules8
6 files changed, 100 insertions, 4 deletions
diff --git a/debian/dhelp b/debian/dhelp
new file mode 100644
index 000000000..6f9ea4654
--- /dev/null
+++ b/debian/dhelp
@@ -0,0 +1,10 @@
+<item>
+<directory>Debian
+<dirtitle>Debian Utilities
+<linkname>APT User's Guide
+<filename>users-guide.html/index.html
+<descrip>
+The APT User's Guide provides an overview of how to use the the APT package
+manager, and provides a detailed look at the apt-get tool.
+</descrip>
+</item>
diff --git a/debian/libapt-pkg-doc.dhelp b/debian/libapt-pkg-doc.dhelp
new file mode 100644
index 000000000..cdf90680b
--- /dev/null
+++ b/debian/libapt-pkg-doc.dhelp
@@ -0,0 +1,61 @@
+<item>
+<directory>devel
+<dirtitle>Development Tools
+<linkname>APT Cache Specification
+<filename>/usr/doc/apt/cache.html/index.html
+<descrip>
+The APT Cache Specification describes the complete implementation and
+format of the APT Cache file. The APT Cache file is a way for APT to parse
+and store a large number of package files for display in the UI. It's primary
+design goal is to make display of a single package in the tree very
+fast by pre-linking important things like dependencies and provides.
+The specification doubles as documentation for one of the in-memory
+structures used by the package library and the APT GUI.
+</descrip>
+</item>
+
+<item>
+<directory>devel
+<dirtitle>Development Tools
+<linkname>APT Design Document
+<filename>/usr/doc/apt/design.html/index.html
+<descrip>
+The APT Design Document is an overview of the specifications and design goals
+of the APT project. It also attempts to give a broad description of the
+implementation as well.
+</descrip>
+</item>
+
+<item>
+<directory>devel
+<dirtitle>Development Tools
+<linkname>DPkg Technical Manual
+<filename>/usr/doc/apt/design.html/index.html
+<descrip>
+The DPkg Technical Manual gives an overview of dpkg's external functions
+and describes how it views the world.
+</descrip>
+</item>
+
+<item>
+<directory>devel
+<dirtitle>Development Tools
+<linkname>APT Files
+<filename>/usr/doc/apt/files.html/index.html
+<descrip>
+The APT Files document describes the complete implementation and format of
+the installed APT directory structure. It also serves as guide to how
+APT views the Debian archive.
+</descrip>
+</item>
+
+<item>
+<directory>devel
+<dirtitle>Development Tools
+<linkname>APT Method Interface
+<filename>/usr/doc/apt/files.html/index.html
+<descrip>
+The APT Method Interface document describes the interface that APT uses to
+the archive access methods.
+</descrip>
+</item>
diff --git a/debian/libapt-pkg-doc.postinst b/debian/libapt-pkg-doc.postinst
new file mode 100755
index 000000000..250bd190c
--- /dev/null
+++ b/debian/libapt-pkg-doc.postinst
@@ -0,0 +1,10 @@
+#! /bin/sh
+
+case "$1" in
+ configure)
+ if [ -f /usr/sbin/dhelp_parse ]; then
+ #/usr/sbin/dhelp_parse -a /usr/doc/libapt-pkg-doc
+ fi
+ ;;
+esac
+
diff --git a/debian/libapt-pkg-doc.prerm b/debian/libapt-pkg-doc.prerm
new file mode 100755
index 000000000..6893d2cda
--- /dev/null
+++ b/debian/libapt-pkg-doc.prerm
@@ -0,0 +1,11 @@
+#! /bin/sh
+
+case "$1" in
+ remove|upgrade|remove-in-favour|deconfigure-in-favour)
+ if [ -f /usr/sbin/dhelp_parse ]; then
+ #/usr/sbin/dhelp_parse -d /usr/doc/libapt-pkg-doc
+ fi
+ ;;
+ failed-upgrade)
+ ;;
+esac
diff --git a/debian/postinst b/debian/postinst
index 3de054186..87476bfc0 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -46,6 +46,8 @@ case "$1" in
else
check_apt_conf
fi
-
+ if [ -f /usr/sbin/dhelp_parse ]; then
+ /usr/sbin/dhelp_parse -a /usr/doc/apt
+ fi
esac
diff --git a/debian/rules b/debian/rules
index 0ee846a53..9ea0d45c6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.3 1999/01/28 06:42:27 jgg Exp $
+# $Id: rules,v 1.4 1999/02/02 02:19:46 jgg Exp $
# Uncomment this to turn on verbose mode.
@@ -61,7 +61,8 @@ apt: build
cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
mkdir debian/tmp/usr/doc/apt/users-guide.html/
cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
-
+ cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
+
# head -n 500 ChangeLog > debian/ChangeLog
dh_installdocs -papt
@@ -109,10 +110,11 @@ libapt-pkg-doc: build
dh_testdir -plibapt-pkg-doc
dh_testroot -plibapt-pkg-doc
dh_clean -plibapt-pkg-doc -k
- dh_installdirs -plibapt-pkg-doc usr/doc/apt
+ dh_installdirs -plibapt-pkg-doc usr/doc/apt usr/doc/libapt-pkg-doc
cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
+# sigh cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
dh_installdocs -plibapt-pkg-doc
dh_installchangelogs -plibapt-pkg-doc