summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAdam Conrad <adconrad@ubuntu.com>2012-11-06 15:54:31 -0700
committerMichael Vogt <mvo@debian.org>2013-07-11 07:26:42 +0200
commit50dba2a9ad755f2ce476576f54698128df9ba327 (patch)
tree7c483d4b01c3a884cb08220cf89ebb417563d78d /debian
parent94bfdf69d2b2ae7413ad2a3590d41d7de9a4adbe (diff)
* Fix up two things in debian/apt.auto-removal.sh:
- Use exact matches with $-terminated regexes, so we don't get confusion between similarly-named kernel flavours. - Keep linux-backports-modules in sync with installed kernels. Conflicts: configure.in debian/changelog doc/apt-verbatim.ent
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.auto-removal.sh7
-rw-r--r--debian/changelog6
2 files changed, 10 insertions, 3 deletions
diff --git a/debian/apt.auto-removal.sh b/debian/apt.auto-removal.sh
index 17becd30e..8b0f1cf69 100644
--- a/debian/apt.auto-removal.sh
+++ b/debian/apt.auto-removal.sh
@@ -81,9 +81,10 @@ APT
{
EOF
for kernel in $kernels; do
- echo " \"^linux-image-$kernel.*\";" >> "$config_file".dpkg-new
- echo " \"^linux-image-extra-$kernel.*\";" >> "$config_file".dpkg-new
- echo " \"^linux-signed-image-$kernel.*\";" >> "$config_file".dpkg-new
+ echo " \"^linux-image-${kernel}$\";" >> "$config_file".dpkg-new
+ echo " \"^linux-image-extra-${kernel}$\";" >> "$config_file".dpkg-new
+ echo " \"^linux-signed-image-${kernel}$\";" >> "$config_file".dpkg-new
+ echo " \"^linux-backports-modules-.*-${kernel}$\";" >> "$config_file".dpkg-new
done
cat >> "$config_file".dpkg-new <<EOF
};
diff --git a/debian/changelog b/debian/changelog
index d196bb136..185322bb6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,12 @@ apt (0.9.9.1) UNRELEASED; urgency=low
newest kernel, so we don't fill /boot up with an unlimited number of
kernels. LP: #923876.
+ [ Adam Conrad ]
+ * Fix up two things in debian/apt.auto-removal.sh:
+ - Use exact matches with $-terminated regexes, so we don't get
+ confusion between similarly-named kernel flavours.
+ - Keep linux-backports-modules in sync with installed kernels.
+
-- Michael Vogt <michael.vogt@ubuntu.com> Fri, 05 Jul 2013 16:39:34 +0200
apt (0.9.9) unstable; urgency=low