summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2014-02-13 14:29:20 +0100
committerMichael Vogt <mvo@debian.org>2014-02-13 14:29:20 +0100
commit784e35e86293094bb5c1456c8f9c844df2a71f12 (patch)
tree28073f068ca09c46c04a5ed9e047824f782b15ac /debian
parenta84a4d2ab78c498d9797c07d463daec4095b37de (diff)
parent28b4b983d95fa742a5431547285a748e8b856399 (diff)
Merge branch 'debian/sid' into ubuntu/master
Conflicts: configure.ac debian/changelog
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog24
-rw-r--r--debian/control2
-rw-r--r--debian/libapt-pkg4.12.symbols21
-rw-r--r--debian/tests/control3
-rw-r--r--debian/tests/run-tests5
5 files changed, 47 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 7196d760c..446f2295a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,27 @@
+apt (0.9.15.2) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * move isatty() check into InitOutput()
+ * Use a APT::VersionSet instead of a VersionList
+ (closes: #738103)
+
+ [ David Kalnischkies ]
+ * simplify code to make compilers happy
+ * update libapt-pkg.symbols file
+ * bump Standards-Version to 3.9.5 (no changes needed)
+ * do not use an empty APT_CONFIG environment variable
+ * always cleanup patchfiles at the end of rred call
+ * use VersionSet in download to handle repeats (Closes: 738103)
+ * use utimes instead of utimensat/futimens (Closes: 738567)
+
+ [ John Ogness ]
+ * apt-cdrom should succeed if any drive succeeds (Closes: 728153)
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (621t): Update and review
+
+ -- Michael Vogt <mvo@debian.org> Thu, 13 Feb 2014 09:50:04 +0100
+
apt (0.9.15.1ubuntu1) trusty; urgency=low
* merged from debian/sid
diff --git a/debian/control b/debian/control
index 527a8d65f..b9a468479 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
XSBC-Original-Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Michael Vogt <mvo@debian.org>, Christian Perrier <bubulle@debian.org>,
Julian Andres Klode <jak@debian.org>
-Standards-Version: 3.9.4
+Standards-Version: 3.9.5
Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 8.1.3~), libdb-dev,
gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.4~),
zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml,
diff --git a/debian/libapt-pkg4.12.symbols b/debian/libapt-pkg4.12.symbols
index af43a7b07..3236d227a 100644
--- a/debian/libapt-pkg4.12.symbols
+++ b/debian/libapt-pkg4.12.symbols
@@ -1459,7 +1459,6 @@ libapt-pkg.so.4.12 libapt-pkg4.12 #MINVER#
(c++)"APT::Progress::PackageManagerFancy::~PackageManagerFancy()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManagerFancy::PackageManagerFancy()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManagerFancy::SetupTerminalScrollArea(int)@Base" 0.9.13~exp1
- (c++)"APT::Progress::PackageManagerFancy::Start()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManagerFancy::StatusChanged(std::basic_string<char, std::char_traits<char>, std::allocator<char> >, unsigned int, unsigned int, std::basic_string<char, std::char_traits<char>, std::allocator<char> >)@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManagerFancy::Stop()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManager::fork()@Base" 0.9.13~exp1
@@ -1483,7 +1482,6 @@ libapt-pkg.so.4.12 libapt-pkg4.12 #MINVER#
(c++)"APT::Progress::PackageManagerProgressFd::Stop()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManagerProgressFd::WriteToStatusFd(std::basic_string<char, std::char_traits<char>, std::allocator<char> >)@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManager::Pulse()@Base" 0.9.13~exp1
- (c++)"APT::Progress::PackageManager::Start()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManager::StartDpkg()@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManager::StatusChanged(std::basic_string<char, std::char_traits<char>, std::allocator<char> >, unsigned int, unsigned int, std::basic_string<char, std::char_traits<char>, std::allocator<char> >)@Base" 0.9.13~exp1
(c++)"APT::Progress::PackageManager::Stop()@Base" 0.9.13~exp1
@@ -1512,6 +1510,23 @@ libapt-pkg.so.4.12 libapt-pkg4.12 #MINVER#
(c++)"vtable for APT::Progress::PackageManagerProgressDeb822Fd@Base" 0.9.13~exp1
(c++)"vtable for APT::Progress::PackageManagerProgressFd@Base" 0.9.13~exp1
(c++)"vtable for APT::Progress::PackageManagerText@Base" 0.9.13~exp1
+ (c++)"APT::Progress::PackageManagerFancy::instances@Base" 0.9.14.2
+ (c++)"APT::Progress::PackageManagerFancy::Start(int)@Base" 0.9.14.2
+ (c++)"APT::Progress::PackageManagerFancy::staticSIGWINCH(int)@Base" 0.9.14.2
+ (c++)"APT::Progress::PackageManager::Start(int)@Base" 0.9.14.2
+### client-side merged pdiffs
+ (c++)"pkgAcqIndexMergeDiffs::DescURI()@Base" 0.9.14.3~exp1
+ (c++)"pkgAcqIndexMergeDiffs::Done(std::basic_string<char, std::char_traits<char>, std::allocator<char> >, unsigned long long, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, pkgAcquire::MethodConfig*)@Base" 0.9.14.3~exp1
+ (c++)"pkgAcqIndexMergeDiffs::Failed(std::basic_string<char, std::char_traits<char>, std::allocator<char> >, pkgAcquire::MethodConfig*)@Base" 0.9.14.3~exp1
+ (c++)"pkgAcqIndexMergeDiffs::~pkgAcqIndexMergeDiffs()@Base" 0.9.14.3~exp1
+ (c++)"pkgAcqIndexMergeDiffs::pkgAcqIndexMergeDiffs(pkgAcquire*, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, HashString const&, DiffInfo const&, std::vector<pkgAcqIndexMergeDiffs*, std::allocator<pkgAcqIndexMergeDiffs*> > const*)@Base" 0.9.14.3~exp1
+ (c++)"typeinfo for pkgAcqIndexMergeDiffs@Base" 0.9.14.3~exp1
+ (c++)"typeinfo name for pkgAcqIndexMergeDiffs@Base" 0.9.14.3~exp1
+ (c++)"vtable for pkgAcqIndexMergeDiffs@Base" 0.9.14.3~exp1
+### deb822 sources.list format
+ (c++)"pkgSourceList::ParseFileDeb822(std::basic_string<char, std::char_traits<char>, std::allocator<char> >)@Base" 0.9.14.3~exp1
+ (c++)"pkgSourceList::ParseFileOldStyle(std::basic_string<char, std::char_traits<char>, std::allocator<char> >)@Base" 0.9.14.3~exp1
+ (c++)"pkgSourceList::Type::ParseStanza(std::vector<metaIndex*, std::allocator<metaIndex*> >&, pkgTagSection&, int, FileFd&)@Base" 0.9.14.3~exp1
### mixed stuff
(c++)"GetListOfFilesInDir(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, bool)@Base" 0.8.16~exp13
(c++)"pkgCache::DepIterator::IsIgnorable(pkgCache::PkgIterator const&) const@Base" 0.8.16~exp10
@@ -1570,6 +1585,8 @@ libapt-pkg.so.4.12 libapt-pkg4.12 #MINVER#
(c++)"HashString::FromFile(std::basic_string<char, std::char_traits<char>, std::allocator<char> >)@Base" 0.9.13.1
(c++)"HashString::GetHashForFile(std::basic_string<char, std::char_traits<char>, std::allocator<char> >) const@Base" 0.9.13.1
(c++)"indexRecords::GetSuite() const@Base" 0.9.13.2
+ (c++)"GetTempDir()@Base" 0.9.14.2
+ (c++|optional=private)"pkgCdrom::MountAndIdentCDROM(Configuration&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, pkgCdromStatus*)@Base" 0.9.15.2
### demangle strangeness - buildd report it as MISSING and as new…
(c++)"pkgAcqMetaSig::pkgAcqMetaSig(pkgAcquire*, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::vector<IndexTarget*, std::allocator<IndexTarget*> > const*, indexRecords*)@Base" 0.8.0
### gcc artefacts
diff --git a/debian/tests/control b/debian/tests/control
index e38921c7e..ae794f762 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,2 +1,3 @@
Tests: run-tests
-Depends: @, dpkg-dev, debhelper, libdb-dev, gettext, libcurl4-gnutls-dev, zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml, po4a, autotools-dev, autoconf, automake, doxygen, debiandoc-sgml, stunnel4 \ No newline at end of file
+Restrictions: allow-stderr
+Depends: @, apt, dpkg-dev, debhelper, libdb-dev, gettext, libcurl4-gnutls-dev, zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml, po4a, autotools-dev, autoconf, automake, doxygen, debiandoc-sgml, stunnel4
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index 233c5a386..d9a9db7bf 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -2,12 +2,9 @@
set -e
-# auto-package-test is very unhappy if stuff it writen to stderr
-exec 2> apt-stderr.log
-
# we need the buildin webserver for the tests
if [ ! -e environment.mak ]; then
- ./configure
+ make startup
fi
make -C test/interactive-helper/