summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2014-02-28 20:28:08 +0100
committerMichael Vogt <mvo@debian.org>2014-02-28 20:28:08 +0100
commit8c55d4d117f1641650cd832c957ccdbf71b04893 (patch)
treeaa69ee9a261598e565619fd39e2f4c131106713a /debian
parent821197c1198547077a8a0de5ebbb1b355ec33572 (diff)
parented9665aedf77b3b8345bd4ed33de7885738e29f0 (diff)
Merge branch 'debian/sid' into ubuntu/master
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/tests/control2
-rw-r--r--debian/tests/run-tests4
3 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e817d4884..338890445 100755
--- a/debian/rules
+++ b/debian/rules
@@ -209,6 +209,9 @@ apt: build-binary build-manpages debian/apt.install
#mv debian/$@/usr/bin/apt-report-mirror-failure \
# debian/$@/usr/lib/apt/apt-report-mirror-failure \
+ # move the apt-helper in place
+ mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+
dh_bugfiles -p$@
dh_lintian -p$@
dh_installexamples -p$@ $(BLD)/docs/examples/*
diff --git a/debian/tests/control b/debian/tests/control
index 12490a36f..209f16bfd 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,3 +1,3 @@
Tests: run-tests
Restrictions: allow-stderr
-Depends: @, dpkg-dev, debhelper, libdb-dev, gettext, libcurl4-gnutls-dev, zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml, po4a, autotools-dev, autoconf, automake, doxygen, debiandoc-sgml, stunnel4, libdb-dev
+Depends: @, build-essential, fakeroot, wget, dpkg-dev, debhelper, libdb-dev, gettext, libcurl4-gnutls-dev, zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml, po4a, autotools-dev, autoconf, automake, doxygen, debiandoc-sgml, stunnel4, libdb-dev
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index d9a9db7bf..e03db9b0c 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -2,6 +2,9 @@
set -e
+unset LANGUAGE
+export LC_ALL=C
+
# we need the buildin webserver for the tests
if [ ! -e environment.mak ]; then
make startup
@@ -11,5 +14,6 @@ make -C test/interactive-helper/
# run against the installed apt
APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
./test/integration/run-tests