summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2004-12-23 11:29:13 +0000
committerMichael Vogt <mvo@debian.org>2004-12-23 11:29:13 +0000
commita789b983b99696793857dd58f6d4ea1efe17470e (patch)
tree198cdd2c03d202abec9e79a91081574b934fcccd /debian
parent5f0ccad882f7d811e4bea2a7b269f32be2fb1bd9 (diff)
* changelog updated, version is now 0.6.27ubuntu4; added DEB_BUILD_PROG_OPTS to debian/rules
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rwxr-xr-xdebian/rules2
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f32aa5a94..7825c85a9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+apt (0.6.27ubuntu4) hoary; urgency=low
+
+ * if a sign-file download fails, delete the the partial downloaded
+ file in "partial/"
+ * added apt-key update method (uses ubuntu-keyring)
+ * documented the "--allow-unauthenticated" switch
+ * added DEB_BUILD_PROG_OPTS to debian/rules (additonal options can be
+ passed to DEB_BUILD_PROG like "-S")
+
+ -- Michael Vogt <mvo@debian.org> Thu, 23 Dec 2004 11:12:51 +0100
+
apt (0.6.27ubuntu3) hoary; urgency=low
* added a exact dependency from libapt-pkg-dev to the apt version it was
diff --git a/debian/rules b/debian/rules
index 1fbbb61d1..b756b3b32 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,7 +36,7 @@ endif
# Default rule
build:
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')