summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:55:52 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:55:52 +0000
commitb024fa2565b194e9848a1714342a81d9744e20ec (patch)
tree448f519661780c299d55ae7a4091f143164b0abe /debian
parenta880aa747674f5ac5b01ece8bfa617fcffba74f5 (diff)
Fix for out of order compliations
Author: jgg Date: 2000-05-10 05:59:12 GMT Fix for out of order compliations
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 05dbc4603..1da162948 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.19 1999/12/07 07:38:19 jgg Exp $
+# $Id: rules,v 1.20 2000/05/10 05:59:12 jgg Exp $
# For the deb builder, you can run 'debian/rules cvs-build', which does all
@@ -27,6 +27,10 @@ BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
override BLD := $(BUILDX)
+ifeq ($(words $(BLD)),0)
+override BLD := ./build
+endif
+
ifneq ($(APT_DEBVER),$(APT_CONFVER))
.PHONY: configure.in
configure.in: