summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@canonical.com>2012-06-11 15:16:27 -0700
committerSteve Langasek <steve.langasek@canonical.com>2012-06-11 15:16:27 -0700
commitcc68ddf9045d6663dfb4f4fddf6c2b27de7144f6 (patch)
tree0f1f9b841c8c52c7b0ab258ed46f44e31154ff3d /debian
parent825098c2740b2d5ebea0c16c43685f55da201315 (diff)
Drop upgrade handling for obsolete conffile /etc/apt/apt.conf.d/01ubuntu,
removed in previous LTS.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/control1
-rwxr-xr-xdebian/postinst3
-rwxr-xr-xdebian/postrm3
-rwxr-xr-xdebian/preinst3
5 files changed, 5 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index fc638b2f1..e1b855a89 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
apt (0.9.6ubuntu1) UNRELEASED; urgency=low
+ [ Michael Vogt ]
* merged from Debian, remaining changes:
- use ubuntu keyring and ubuntu archive keyring in apt-key
- run update-apt-xapian-index in apt.cron
@@ -11,6 +12,10 @@ apt (0.9.6ubuntu1) UNRELEASED; urgency=low
- ubuntu changelog download handling
- patch for apt cross-building, see http://bugs.debian.org/666772
+ [ Steve Langasek ]
+ * Drop upgrade handling for obsolete conffile /etc/apt/apt.conf.d/01ubuntu,
+ removed in previous LTS.
+
-- Michael Vogt <michael.vogt@ubuntu.com> Tue, 22 May 2012 15:57:26 +0200
apt (0.9.6) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 785643bf3..4bdd3ce70 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,6 @@ Vcs-Browser: http://code.launchpad.net/apt/ubuntu
Package: apt
Architecture: any
-Pre-Depends: dpkg (>= 1.15.7.2)
Depends: ubuntu-keyring, ${shlibs:Depends}, ${misc:Depends}, gnupg
Replaces: manpages-pl (<< 20060617-3~)
Conflicts: python-apt (<< 0.7.93.2~)
diff --git a/debian/postinst b/debian/postinst
index eb2a67d0e..1588f5241 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -10,9 +10,6 @@
set -e
-dpkg-maintscript-helper rm_conffile /etc/apt/apt.conf.d/01ubuntu \
- 0.8.16~exp12ubuntu6 -- "$@"
-
create_apt_conf ()
{
EXAMPLE_SOURCE=/usr/share/doc/apt/examples/sources.list
diff --git a/debian/postrm b/debian/postrm
index bb19d32cc..ae1e18d33 100755
--- a/debian/postrm
+++ b/debian/postrm
@@ -12,9 +12,6 @@ set -e
#DEBHELPER#
-dpkg-maintscript-helper rm_conffile /etc/apt/apt.conf.d/01ubuntu \
- 0.8.16~exp12ubuntu6 -- "$@"
-
case "$1" in
remove)
;;
diff --git a/debian/preinst b/debian/preinst
index 6ccdfb1a3..985ad9b84 100755
--- a/debian/preinst
+++ b/debian/preinst
@@ -7,9 +7,6 @@ set -e
# rm /var/state/apt
#fi
-dpkg-maintscript-helper rm_conffile /etc/apt/apt.conf.d/01ubuntu \
- 0.8.16~exp12ubuntu6 -- "$@"
-
if [ "$1" = "upgrade" -o "$1" = "install" -a "$2" != "" ]; then
if [ ! -e /var/lib/apt -a -e /var/state/apt ]; then
# upgrading from /var/state/apt using apt.