summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2010-09-17 15:06:38 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2010-09-17 15:06:38 +0200
commitcdf13dc287dcd4603152339364d894601e4a6c05 (patch)
tree819b63c085d1c5e2df506e1d09599949957647ae /debian
parent3b3a681c79d3e5c32fcd6ccb87e74e5ca6e234b4 (diff)
parent9ef21af3d8325ef6889fdf9f015b497a71c9f845 (diff)
merged from lp:~donkult/apt/sid
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily43
-rw-r--r--debian/changelog19
-rw-r--r--debian/control2
3 files changed, 32 insertions, 32 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 8c0e4c416..8ace14a31 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -11,7 +11,7 @@
# Dir::Cache "var/apt/cache/";
# - Set apt package cache directory
#
-# Dir::Cache::Archive "archives/";
+# Dir::Cache::Archives "archives/";
# - Set package archive directory
#
# APT::Periodic::Enable "1";
@@ -147,21 +147,14 @@ check_size_constraints()
eval $(apt-config shell MaxSize APT::Archives::MaxSize)
eval $(apt-config shell MaxSize APT::Periodic::MaxSize)
- CacheDir="var/cache/apt/"
- eval $(apt-config shell CacheDir Dir::Cache)
- CacheDir=${CacheDir%/}
-
- CacheArchive="archives/"
- eval $(apt-config shell CacheArchive Dir::Cache::archives)
- CacheArchive=${CacheArchive%/}
+ Cache="/var/cache/apt/archives/"
+ eval $(apt-config shell Cache Dir::Cache::archives/d)
# sanity check
- if [ -z "$CacheDir" -o -z "$CacheArchive" ]; then
- echo "empty Dir::Cache or Dir::Cache::archives, exiting"
+ if [ -z "$Cache" ]; then
+ echo "empty Dir::Cache::archives, exiting"
exit
fi
-
- Cache="${Dir%/}/${CacheDir%/}/${CacheArchive%/}/"
# check age
if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
@@ -225,22 +218,17 @@ do_cache_backup()
fi
# Set default values and normalize
- Dir="/"
- eval $(apt-config shell Dir Dir)
- Dir=${Dir%/}
-
- CacheDir="var/cache/apt/"
- eval $(apt-config shell CacheDir Dir::Cache)
+ CacheDir="/var/cache/apt"
+ eval $(apt-config shell CacheDir Dir::Cache/d)
CacheDir=${CacheDir%/}
if [ -z "$CacheDir" ]; then
debug_echo "practically empty Dir::Cache, exiting"
return 0
fi
- CacheArchive="archives/"
- eval $(apt-config shell CacheArchive Dir::Cache::Archives)
- CacheArchive=${CacheArchive%/}
- if [ -z "$CacheArchive" ]; then
+ Cache="${CacheDir}/archives/"
+ eval $(apt-config shell Cache Dir::Cache::Archives/d)
+ if [ -z "$Cache" ]; then
debug_echo "practically empty Dir::Cache::archives, exiting"
return 0
fi
@@ -251,16 +239,15 @@ do_cache_backup()
BackupLevel=2 ;
fi
- CacheBackup="backup/"
- eval $(apt-config shell CacheBackup Dir::Cache::Backup)
- CacheBackup=${CacheBackup%/}
- if [ -z "$CacheBackup" ]; then
+ Back="${CacheDir}/backup/"
+ eval $(apt-config shell Back Dir::Cache::Backup/d)
+ if [ -z "$Back" ]; then
echo "practically empty Dir::Cache::Backup, exiting" 1>&2
return
fi
- Cache="${Dir}/${CacheDir}/${CacheArchive}/"
- Back="${Dir}/${CacheDir}/${CacheBackup}/"
+ CacheArchive="$(basename "${Cache}")"
+ test -n "${CacheArchive}" || CacheArchive="archives"
BackX="${Back}${CacheArchive}/"
for x in $(seq 0 1 $((${BackupLevel}-1))); do
eval "Back${x}=${Back}${x}/"
diff --git a/debian/changelog b/debian/changelog
index 54e47957d..1d7aeba78 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,17 +1,30 @@
apt (0.8.5) UNRELEASED; urgency=low
+ [ Manpages translations ]
+ * German (Chris Leick). Closes: #597163
+
[ Michael Vogt ]
* merged lp:~mvo/apt/conflicts-on-virtuals to better deal with
conflicts/breaks against virtual packages (LP: #614993)
-
+
[ David Kalnischkies ]
* apt-pkg/policy.cc:
- support 100-pinning in Release file with ButAutomaticUpgrades
as requested by the backports crew (Closes: #596097)
* apt-pkg/deb/deblistparser.cc:
- overrule NotAutomatic in case of ButAutomaticUpgrades
-
- -- David Kalnischkies <kalnischkies@gmail.com> Tue, 14 Sep 2010 18:56:23 +0200
+ * debian/apt.cron.daily:
+ - handle absolut directory paths correctly by loading directories
+ directly instead of building the paths on our own (Closes: #596421)
+ * debian/control:
+ - build-depend on docbook-xml to ensure that the xml DTDs are always
+ available on the buildds (Closes: #597145)
+ * buildlib/debiandoc.mak, buildlib/po4a_manpage.mak:
+ - ensure that the build fails if documentation building fails
+ * doc/po/fr.po:
+ - correct two syntax issues to ensure we can build fine
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Fri, 17 Sep 2010 10:26:17 +0200
apt (0.8.4) unstable; urgency=low
diff --git a/debian/control b/debian/control
index f03b96f67..87e885f6a 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
Standards-Version: 3.9.0
-Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, docbook-xml, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/