summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:53:00 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:53:00 +0000
commitd153f53f46536ead5145e25fa35dd978a0b0a34c (patch)
tree789a92fca736d433b1d5c948f89a6433f52643b8 /debian
parent5496e7f6c9d091c24e2669c90e984540fb48e7ca (diff)
Changes to add virtual package libapt-pkg2.x
Author: mblevin Date: 1999-03-12 22:34:34 GMT Changes to add virtual package libapt-pkg2.x
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules10
3 files changed, 15 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index aa5ae0b00..eabb72168 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+apt (0.3.1) experimental; urgency=low
+
+ * Minor release of cvs version.
+ * Added virtual package libapt-pkgx.x
+
+ -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
+
apt (0.3.0) experimental; urgency=low
* New experimental version.
diff --git a/debian/control b/debian/control
index 466565ebb..f82e95d8e 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,7 @@ Architecture: any
Depends: ${shlibs:Depends}
Conflicts: deity
Replaces: deity
+Provides: libapt-pkg${libapt-pkg:major}
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
It provides the apt-get utility and APT dselect method that provides a
diff --git a/debian/rules b/debian/rules
index 31f2089fb..82c3b0a0c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,12 +2,15 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.6 1999/02/15 08:23:10 jgg Exp $
+# $Id: rules,v 1.7 1999/03/12 22:34:34 mblevin Exp $
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+# Find the libapt-pkg major version for use in other control files
+export LIBAPT_MAJOR=`egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2`
+
build: build-stamp
build-stamp: configure
dh_testdir
@@ -87,8 +90,9 @@ apt: build
dh_suidregister -papt
dh_installdeb -papt
LD_LIBRARY_PATH=debian/tmp/usr/lib dh_shlibdeps -papt
+ echo libapt-pkg:major=${LIBAPT_MAJOR} >> debian/substvars
dh_gencontrol -papt
- dh_makeshlibs -papt
+ dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
dh_md5sums -papt
dh_builddeb -papt
@@ -98,7 +102,7 @@ libapt-pkg-dev: build
dh_clean -plibapt-pkg-dev -k
dh_installdirs -plibapt-pkg-dev usr/lib usr/include/apt-pkg
- ln -s libapt-pkg.so.2.0 debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+ ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/