summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2007-08-03 12:18:12 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2007-08-03 12:18:12 +0200
commitf060e833f53ba3ed0024f8a2bebfc78e8aa552f2 (patch)
treeccf327402d9e02f24fdf95065c06c7a5dd2fa650 /debian
parent3e8bdb6fe22d6feeca07d47e07c9b79ddd882c59 (diff)
parentc3279b9d100fb62f412267512458b58dda40f95b (diff)
* apt-inst/contrib/extracttar.cc:
- fix fd leak for zero size files (thanks to Bill Broadley for reporting this bug) * apt-pkg/acquire-item.cc: - remove zero size files on I-M-S hit * methods/https.cc: - only send LastModified if we actually have one - send range request with if-range - delete failed downloads * apt-pkg/deb/dpkgpm.{cc,h}: - merged dpkg-log branch, this lets you specify a Dir::Log::Terminal file to log dpkg output to (ABI break) * merged apt--sha256 branch to fully support the new sha256 checksums in the Packages and Release files (ABI break) * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong directory downloading on non-linux architectures (closes: #435597) * Applied patch from Guillem Jover <guillem@debian.org> to use * Applied patch from Guillem Jover <guillem@debian.org> to add support to add lzma support (closes: #408201) * methods/makefile: - install lzma symlink method (for full lzma support) * debian/control: - suggest "lzma" * Simplified HttpMethod::Fetch on http.cc removing Tail variable; * Fix pipeline handling on http.cc (closes: #413324) * Fix building to properly support binNMUs. Thanks to Daniel Schepler <schepler@math.unipd.it> by the patch (closes: #359634) * Fix example for Install-{Recommends,Suggests} options on configure-index example file. Thanks to Peter Eisentraut <peter_e@gmx.net> by the patch (closes: #432223) * fixed compile errors with g++ 4.3 (thanks to Daniel Burrows, closes: #429378) * fixes in the auto-mark code (thanks to Daniel Burrows) * fix FTFBFS by changing build-depends to libcurl4-gnutls-dev (closes: #428363) * cmdline/apt-get.cc: - fix InstallTask code when a pkgRecord ends with a single '\n' (thanks to Soren Hansen for reporting) * merged from Christian Perrier: * vi.po: completed to 532t, again. Closes: #429899 * gl.po: completed to 532t. Closes: #429506 * vi.po: completed to 532t. Closes: #428672 * Update all PO and the POT. Gives 514t14f4u for formerly complete translations * fr.po: completed to 532t * ku.po, uk.po, LINGUAS: reintegrate those translations which disappeared from the BZR repositories
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.dirs2
-rw-r--r--debian/apt.logrotate8
-rw-r--r--debian/changelog75
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules1
5 files changed, 84 insertions, 4 deletions
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 025898e84..2db8dca9a 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -4,8 +4,10 @@ usr/lib/dpkg/methods/apt
etc/apt
etc/apt/apt.conf.d
etc/apt/sources.list.d
+etc/logrotate.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
var/lib/apt/mirrors/partial
var/lib/apt/periodic
+var/log/apt
usr/share/bug/apt
diff --git a/debian/apt.logrotate b/debian/apt.logrotate
new file mode 100644
index 000000000..3e924d383
--- /dev/null
+++ b/debian/apt.logrotate
@@ -0,0 +1,8 @@
+/var/log/apt/term.log {
+ rotate 6
+ monthly
+ compress
+ missingok
+ notifempty
+}
+
diff --git a/debian/changelog b/debian/changelog
index bee947ae3..02b637553 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,53 @@
-apt (0.7.4ubuntu1) gutsy; urgency=low
+apt (0.7.6ubuntu1) gutsy; urgency=low
+
+ * apt-inst/contrib/extracttar.cc:
+ - fix fd leak for zero size files (thanks to Bill Broadley for
+ reporting this bug)
+ * apt-pkg/acquire-item.cc:
+ - remove zero size files on I-M-S hit
+ * methods/https.cc:
+ - only send LastModified if we actually have one
+ - send range request with if-range
+ - delete failed downloads
+ * apt-pkg/deb/dpkgpm.{cc,h}:
+ - merged dpkg-log branch, this lets you specify a
+ Dir::Log::Terminal file to log dpkg output to
+ (ABI break)
+ * merged apt--sha256 branch to fully support the new
+ sha256 checksums in the Packages and Release files
+ (ABI break)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 02 Aug 2007 11:55:54 +0200
+
+apt (0.7.6) unstable; urgency=low
+
+ * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
+ directory downloading on non-linux architectures (closes: #435597)
+
+ -- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
+
+apt (0.7.5) unstable; urgency=low
[ Otavio Salvador ]
- * Applied patch from Guillem Jover <guillem.jover@nokia.com> to use
+ * Applied patch from Guillem Jover <guillem@debian.org> to use
dpkg-architecture to get the host architecture (closes: #407187)
+ * Applied patch from Guillem Jover <guillem@debian.org> to add
+ support to add lzma support (closes: #408201)
[ Michael Vogt ]
* apt-pkg/depcache.cc:
- support a list of sections for:
APT::Install-Recommends-Sections
APT::Never-MarkAuto-Sections
+ * methods/makefile:
+ - install lzma symlink method (for full lzma support)
+ * debian/control:
+ - suggest "lzma"
+
+ -- Otavio Salvador <otavio@ossystems.com.br> Wed, 25 Jul 2007 20:16:46 -0300
+
+apt (0.7.4ubuntu1) gutsy; urgency=low
+
* debian/apt.conf.ubuntu, apt.conf.autoremove:
- Change metapackages to {restricted,universe,multiverse}/metapackages
in Install-Recommends-Sections and Never-MarkAuto-Sections
@@ -34,6 +73,13 @@ apt (0.7.4) unstable; urgency=low
- type conversion;
- unused variable;
- changed SetupProxy() method to void;
+ * Simplified HttpMethod::Fetch on http.cc removing Tail variable;
+ * Fix pipeline handling on http.cc (closes: #413324)
+ * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+ <schepler@math.unipd.it> by the patch (closes: #359634)
+ * Fix example for Install-{Recommends,Suggests} options on
+ configure-index example file. Thanks to Peter Eisentraut
+ <peter_e@gmx.net> by the patch (closes: #432223)
[ Christian Perrier ]
* Basque translation update. Closes: ##423766
@@ -45,6 +91,29 @@ apt (0.7.4) unstable; urgency=low
-- Otavio Salvador <otavio@debian.org> Tue, 24 Jul 2007 09:55:50 -0300
+apt (0.7.3) unstable; urgency=low
+
+ * fixed compile errors with g++ 4.3 (thanks to
+ Daniel Burrows, closes: #429378)
+ * fixes in the auto-mark code (thanks to Daniel
+ Burrows)
+ * fix FTFBFS by changing build-depends to
+ libcurl4-gnutls-dev (closes: #428363)
+ * cmdline/apt-get.cc:
+ - fix InstallTask code when a pkgRecord ends
+ with a single '\n' (thanks to Soren Hansen for reporting)
+ * merged from Christian Perrier:
+ * vi.po: completed to 532t, again. Closes: #429899
+ * gl.po: completed to 532t. Closes: #429506
+ * vi.po: completed to 532t. Closes: #428672
+ * Update all PO and the POT. Gives 514t14f4u for formerly
+ complete translations
+ * fr.po: completed to 532t
+ * ku.po, uk.po, LINGUAS: reintegrate those translations
+ which disappeared from the BZR repositories
+
+ -- Michael Vogt <mvo@debian.org> Sun, 01 Jul 2007 12:31:29 +0200
+
apt (0.7.2ubuntu7) gutsy; urgency=low
* fix build-dependencies
@@ -226,7 +295,7 @@ apt (0.7.1) experimental; urgency=low
* apt-pkg/policy.cc:
- allow multiple packages (thanks to David Foerster)
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 17 Apr 2007 15:53:37 +0200
+ -- Michael Vogt <mvo@debian.org> Wed, 2 May 2007 13:43:44 +0200
apt (0.6.46.4ubuntu10) feisty; urgency=low
diff --git a/debian/control b/debian/control
index 1c6d2f490..ac14c5e0b 100644
--- a/debian/control
+++ b/debian/control
@@ -16,7 +16,7 @@ Priority: important
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
Recommends: ubuntu-keyring
-Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2, gnupg
+Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2, gnupg, lzma
Section: admin
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
diff --git a/debian/rules b/debian/rules
index a330d6dc1..a46169a7b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -209,6 +209,7 @@ apt: build debian/shlibs.local
cp -r $(BLD)/locale debian/$@/usr/share/
cp debian/bugscript debian/$@/usr/share/bug/apt/script
+ cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove