summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2013-08-17 09:18:36 +0200
committerMichael Vogt <mvo@debian.org>2013-08-17 09:18:36 +0200
commitf49d103adc47c5c34f4ca852605ee55710e486b9 (patch)
treeeb63a4d80a82b2d9f9aa5bc25165a21cb38b215f /debian
parentb55e706a8794d810fb7c5a7c175c04ea207b1ce7 (diff)
parentdd4d9729975fc2de37cd69220bc05efb16badc77 (diff)
Merge remote-tracking branch 'mvo/feature/apt-binary2' into debian/sid
Conflicts: cmdline/apt-get.cc
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.install.in (renamed from debian/apt.install)1
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules4
3 files changed, 6 insertions, 2 deletions
diff --git a/debian/apt.install b/debian/apt.install.in
index 9d4008fab..3527f9005 100644
--- a/debian/apt.install
+++ b/debian/apt.install.in
@@ -2,3 +2,4 @@ bin/apt-* usr/bin/
bin/methods/* usr/lib/apt/methods/
scripts/dselect/* usr/lib/dpkg/methods/apt/
usr/share/locale/*/*/apt.mo
+bin/libapt-private* usr/lib/@DEB_HOST_MULTIARCH@/ \ No newline at end of file
diff --git a/debian/changelog b/debian/changelog
index 76e1bc1fb..bd6357c62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ apt (0.9.11) UNRELEASED; urgency=low
configuration
* lp:~mvo/apt/add-glob-function:
- add Glob() to fileutl.{cc,h}
+ * feature/apt-binary2
+ - refactor large chunks of cmdline/*.cc into a new libapt-private
+ library that is shared between the internal apt cmdline tools
-- Michael Vogt <michael.vogt@ubuntu.com> Thu, 15 Aug 2013 09:27:35 +0200
diff --git a/debian/rules b/debian/rules
index fc44d5a68..06ccdac31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -115,7 +115,7 @@ clean:
[ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
- debian/libapt-pkg-dev.install
+ debian/libapt-pkg-dev.install debian/apt.install
test ! -L buildlib/config.guess || rm -f buildlib/config.guess
test ! -L buildlib/config.sub || rm -f buildlib/config.sub
@@ -174,7 +174,7 @@ apt-doc: build-debiandoc
# Build architecture-dependent files here.
apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build-binary build-manpages
+apt: build-binary build-manpages debian/apt.install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@