summaryrefslogtreecommitdiff
path: root/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2020-11-25 18:02:03 +0000
committerJulian Andres Klode <jak@debian.org>2020-11-25 18:02:03 +0000
commit6530ce64d2337ab309d6c974202243abb09d2d04 (patch)
tree20e5a01e2c7c206ccf8d4d7f72f6416b4118218d /methods/CMakeLists.txt
parent1077af2e635df738f351d5ea3515804a4de367ea (diff)
parente5bb443cf58cec23503ad0deeeb06a080053da8a (diff)
Merge branch 'feature/rred' into 'master'
Enhance rred for possible external usage See merge request apt-team/apt!136
Diffstat (limited to 'methods/CMakeLists.txt')
-rw-r--r--methods/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/methods/CMakeLists.txt b/methods/CMakeLists.txt
index d575382f7..a5a360217 100644
--- a/methods/CMakeLists.txt
+++ b/methods/CMakeLists.txt
@@ -23,6 +23,8 @@ target_include_directories(http PRIVATE $<$<BOOL:${SYSTEMD_FOUND}>:${SYSTEMD_INC
target_link_libraries(http ${GNUTLS_LIBRARIES} $<$<BOOL:${SYSTEMD_FOUND}>:${SYSTEMD_LIBRARIES}>)
target_link_libraries(ftp ${GNUTLS_LIBRARIES})
+target_link_libraries(rred apt-private)
+
# Install the library
install(TARGETS file copy store gpgv cdrom http ftp rred rsh mirror
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/apt/methods)