summaryrefslogtreecommitdiff
path: root/test/interactive-helper/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-09-11 13:58:40 +0200
committerJulian Andres Klode <jak@debian.org>2016-09-11 17:44:17 +0200
commitbccb344412a0e97afdf0aaaf41a31124c84f6eaa (patch)
treec57341872a3d83bc5a01ea5b45d9b25d631afacc /test/interactive-helper/CMakeLists.txt
parent422a2eba84361a8dfd84b549c13037512779c572 (diff)
Coverage: Do not print messages from gcov
We need to ignore messages from gcov. All those messages start with profiling: and are printed using vfprintf(), so the only thing we can do is add a library overriding those functions and linking apt-pkg to it.
Diffstat (limited to 'test/interactive-helper/CMakeLists.txt')
-rw-r--r--test/interactive-helper/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/interactive-helper/CMakeLists.txt b/test/interactive-helper/CMakeLists.txt
index fc08d6a8f..423fa30e6 100644
--- a/test/interactive-helper/CMakeLists.txt
+++ b/test/interactive-helper/CMakeLists.txt
@@ -8,3 +8,6 @@ add_executable(aptwebserver aptwebserver.cc)
target_link_libraries(aptwebserver apt-pkg ${CMAKE_THREAD_LIBS_INIT})
add_executable(test_fileutl test_fileutl.cc)
target_link_libraries(test_fileutl apt-pkg)
+
+add_library(noprofile SHARED libnoprofile.c)
+target_link_libraries(noprofile ${CMAKE_DL_LIBS})