summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82b7e73a6..edf98fbeb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,12 @@ if test "x$HAVE_LZMA" = "xyes"; then
AC_DEFINE(HAVE_LZMA)
fi
+HAVE_SYSTEMD=no
+AC_SUBST(HAVE_SYSTEMD)
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221],
+ [HAVE_SYSTEMD=yes
+ AC_DEFINE(HAVE_SYSTEMD)])
+
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
dnl First check against the full canonical canoncial-system-type in $target