summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules10
3 files changed, 13 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e63657bc..1505aad53 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-apt (0.9.7.1) UNRELEASED; urgency=low
+apt (0.9.7.1) unstable; urgency=low
[ Program translation updates ]
* Bulgarian (Damyan Ivanov) (Closes: #678983)
@@ -14,8 +14,12 @@ apt (0.9.7.1) UNRELEASED; urgency=low
* debian/control:
- libapt-{pkg,inst} packages should be in section 'libs' instead
of 'admin' as by ftp-master override request in #677596
+ - demote debiandoc-sgml to Build-Depends-Indep
+ * doc/makefile:
+ - separate translation building of debiandoc from manpages
+ so that we don't need to build debiandoc for binary packages
- -- David Kalnischkies <kalnischkies@gmail.com> Mon, 25 Jun 2012 18:07:13 +0200
+ -- Michael Vogt <mvo@debian.org> Fri, 29 Jun 2012 14:26:32 +0200
apt (0.9.7) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 0020056a8..ec0d817fb 100644
--- a/debian/control
+++ b/debian/control
@@ -9,8 +9,8 @@ Standards-Version: 3.9.3
Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 8.1.3~), libdb-dev,
gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0),
zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml,
- po4a (>= 0.34-2), autotools-dev, autoconf, automake, debiandoc-sgml
-Build-Depends-Indep: doxygen
+ po4a (>= 0.34-2), autotools-dev, autoconf, automake
+Build-Depends-Indep: doxygen, debiandoc-sgml
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
Vcs-Browser: http://bzr.debian.org/loggerhead/apt/debian-sid/
diff --git a/debian/rules b/debian/rules
index ee001fe12..83e23881c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -67,7 +67,7 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
build: build/build-stamp
-build-doc: build-manpages build/build-doc-stamp
+build-debiandoc: build/build-debiandoc-stamp
build-manpages: build/build-manpages-stamp
# Note that this is unconditionally done first as part of loading environment.mak
@@ -98,9 +98,9 @@ else
endif
touch $@
-build/build-doc-stamp: build/build-manpages-stamp build/configure-stamp
+build/build-debiandoc-stamp: build/configure-stamp
# Add here commands to compile the package.
- $(MAKE) doc
+ $(MAKE) debiandoc
touch $@
build/build-manpages-stamp: build/configure-stamp
@@ -121,7 +121,7 @@ debian/%.install: debian/%.install.in
binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
-libapt-pkg-doc: build-doc
+libapt-pkg-doc: build-debiandoc
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -147,7 +147,7 @@ libapt-pkg-doc: build-doc
dh_md5sums -p$@
dh_builddeb -p$@
-apt-doc: build-doc
+apt-doc: build-debiandoc
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@