summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2019-04-04 14:17:37 +0000
committerJulian Andres Klode <jak@debian.org>2019-04-04 14:17:37 +0000
commit0ea7c474182f81e2b7d728569a2fd7b8fa915f3f (patch)
treec917703926593b89f0be93eb4caaf6ee42eadc53 /CMakeLists.txt
parentaea842e1faf5aceebdc046d3d6957a12ae10142d (diff)
parent7c461f0396d413acb9a950f3df9ea6d062896cd7 (diff)
Merge branch 'pkgconfig' into 'master'
Add PkgConfig on the apt-pkg and apt-inst libraries See merge request apt-team/apt!20
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eed22e1a4..29cd30bc6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,6 +191,7 @@ check_cxx_target(HAVE_FMV_SSE42_AND_CRC32DI "sse4.2" "__builtin_ia32_crc32di(0,
set(PACKAGE ${PROJECT_NAME})
set(PACKAGE_MAIL "APT Development Team <deity@lists.debian.org>")
set(PACKAGE_VERSION "1.8.0")
+string(REGEX MATCH "^[0-9.]+" PROJECT_VERSION ${PACKAGE_VERSION})
if (NOT DEFINED DPKG_DATADIR)
execute_process(COMMAND ${PERL_EXECUTABLE} -MDpkg -e "print $Dpkg::DATADIR;"