summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCorentin Noël <corentin.noel@collabora.com>2018-06-03 16:37:44 +0100
committerCorentin Noël <corentin.noel@collabora.com>2019-03-08 19:13:06 +0100
commit7c461f0396d413acb9a950f3df9ea6d062896cd7 (patch)
tree7e6ee54c377af089e9ab788ef963c3a34054aae4 /CMakeLists.txt
parentf541aec06bce1ccac98dabe61137b56ed563e0e9 (diff)
Add pkg-config files for the apt-pkg and apt-inst libraries
Closes: #439121
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c65f99ccd..bce86f502 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -189,6 +189,7 @@ check_cxx_target(HAVE_FMV_SSE42_AND_CRC32DI "sse4.2" "__builtin_ia32_crc32di(0,
set(PACKAGE ${PROJECT_NAME})
set(PACKAGE_MAIL "APT Development Team <deity@lists.debian.org>")
set(PACKAGE_VERSION "1.8.0")
+string(REGEX MATCH "^[0-9.]+" PROJECT_VERSION ${PACKAGE_VERSION})
if (NOT DEFINED DPKG_DATADIR)
execute_process(COMMAND ${PERL_EXECUTABLE} -MDpkg -e "print $Dpkg::DATADIR;"