summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-08-21 22:45:52 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2019-08-21 22:45:52 +0200
commit1aa26d01a9654bdb73ca54d4bb34ff8855723a93 (patch)
tree36b42553a43a1a062564f7d43a9bfc5807308feb /CMakeLists.txt
parenteea584e84a0935a35ff31192c0386e2668cd7df3 (diff)
CMake: Produce a fatal error if triehash could not be found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98e97473b..0487429c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,6 +40,10 @@ find_package(Perl REQUIRED)
find_program(TRIEHASH_EXECUTABLE NAMES triehash)
+if (NOT TRIEHASH_EXECUTABLE)
+ message(FATAL_ERROR "Could not find triehash executable")
+endif()
+
if(USE_NLS)
find_package(Intl REQUIRED)
link_libraries(${Intl_LIBRARIES})