summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-06-30 16:33:09 +0200
committerJulian Andres Klode <jak@debian.org>2017-06-30 16:33:09 +0200
commitc6a428e4d17b408c2701def5daa46ca950948980 (patch)
tree57cb3552e76ff32f7b3a7a758dfa17c53db9d911 /CMakeLists.txt
parent46c31341ef4b09bb3509ebbc49416e34b68e1be4 (diff)
Switch to 'http' as the default https method
The old curl based method is still available as 'curl', 'curl+http', and 'curl+https'.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc15851ce..8bc52036b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,7 @@ endif()
# apt-transport-https dependencies
option(WITH_CURL "Build curl-based methods" ON)
if (WITH_CURL)
+ option(FORCE_CURL "Use curl-based methods" OFF)
find_package(CURL REQUIRED)
if (CURL_FOUND)
set(HAVE_CURL 1)